Search results

  1. H

    Game only leads me to new village

    Did you ever get your problem fixed? I am having a somewhat similar problem and can’t seem to get any help to fix it. I have years invested in the game but feel like if they don’t help me fix my issue (it is in a thread I started) I might as well give up and go find another game to play
  2. H

    Can’t get to my “real” account after switching to new iPad

    B like Big Bug, thanks for the reply. In the help it implies that if I finish the tutorial that they forced me into on the new iPad, I will get a chance to go back to my old account. Anyone know how the devil you get to the end of the tutorial. I have worked my way into the bronze age and spent...
  3. H

    Can’t get to my “real” account after switching to new iPad

    I got a new iPad last week. Transferred everything over from my old iPad and wiped the old one. Started up Dominations on the new iPad this weekend and was forced into a tutorial. Did what seemed like all the tutorial but it was tough to tell and now stuck with a stone age account instead of...
  4. H

    Chat not available?

    After about 4 days of messaging customer support and being told they were working on the issue, they finally fixed it for me. No idea what the problem was or why it took so long to fix. Glad it was fixied but not happy that they were unwilling to do anything to make up for the lost opportunities...
  5. H

    Chat not available?

    Chat has not been available for me for the past 12 hours or so. I can’t request or receive any donations of troops from my alliance because of this. Is this a common problem? Harry
  6. H

    Peace Treaty Reduction

    Yup, they have started up the seasonal leaderboard again, they have come out with a new release, and they still have not addressed the issues that lead to the peace treaty reductions. They need to up them again to 3/4 of the original number of hours or, make other changes to rebalance the game...